All Systems Operational
Cloud ? Operational
90 days ago
100.0 % uptime
Today
Test Recording ? Operational
90 days ago
100.0 % uptime
Today
Authentication Operational
90 days ago
100.0 % uptime
Today
Billing Operational
90 days ago
100.0 % uptime
Today
Integrations Operational
90 days ago
100.0 % uptime
Today
Download ? Operational
90 days ago
100.0 % uptime
Today
Documentation ? Operational
90 days ago
100.0 % uptime
Today
Analytics Operational
90 days ago
100.0 % uptime
Today
Upstream Service Provider ? Operational
Accessibility Operational
90 days ago
99.99 % uptime
Today
UI Coverage Operational
90 days ago
99.99 % uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Past Incidents
Feb 5, 2025

No incidents reported today.

Feb 4, 2025

No incidents reported.

Feb 3, 2025

No incidents reported.

Feb 2, 2025

No incidents reported.

Feb 1, 2025

No incidents reported.

Jan 31, 2025

No incidents reported.

Jan 30, 2025
Resolved - This incident has been resolved.
Jan 30, 14:32 UTC
Monitoring - We have identified the issue and implemented a fix. Monitoring for results.
Jan 30, 14:02 UTC
Investigating - We've identified an issue in viewing Test Replays that is affecting some customers. We are actively investigating.
Jan 30, 13:39 UTC
Jan 29, 2025

No incidents reported.

Jan 28, 2025
Resolved - This incident has been resolved.
Jan 28, 02:14 UTC
Investigating - We have identified an issue that is preventing some Slack and Microsoft Teams messages from being delivered. Engineers are engaged and troubleshooting.
Jan 27, 22:51 UTC
Jan 27, 2025
Jan 26, 2025

No incidents reported.

Jan 25, 2025

No incidents reported.

Jan 24, 2025

No incidents reported.

Jan 23, 2025

No incidents reported.

Jan 22, 2025

No incidents reported.